Printable Version | Subscribe | Add to Favourites
New Topic New Poll New Reply
Author: Subject: EDIS Fun! No Spark
ChrisL

posted on 23/5/19 at 07:52 PM Reply With Quote
EDIS Fun! No Spark

Not sure if this should be here or in Engine/Transmission but here goes:

I'm trying to set up a Microsquirt, and I'm not getting a spark. this is what i've tried so far:

Disconnected the Microsquirt to see if the EDIS will do its 10 degree BTDC magic;
checked the EDIS and coil get 12V which on cranking drops to just over 10V
I've checked the VR sensor wiring and am getting over 2v on cranking using an oscilloscope
I've tried swapping the VR sensor polarity. One thing I have noticed is that there's a connection between the two EDIS coil outputs, which appears to be a tach out and in theory shouldn't be connected and I've not been able to trace it, but I can't imagine why a tach out would be stopping anything

Also checked for a PIP signal, which I think I'm getting, after swapping the VR wires - again:
https://www.dropbox.com/s/5wyvdm9alhkx8tv/PIP.MOV?dl=0

But the output to the coil isnít quite what I was expecting, this is between the middle and the right output on the coil plug:


https://www.dropbox.com/s/owjg9vzg5ujys ... l.MOV?dl=0

Anyone got any ideas or things to test as the can of fuel and a box of matches are looking tempting!

View User's Profile View All Posts By User U2U Member
paulf

posted on 23/5/19 at 08:01 PM Reply With Quote
A standalone edis should be giving a spark, the tacho connection is probably 2 diodes across the coil connections and could be shorting the signal to the coil pack if faulty, I would remove them and try again.
Paul.

View User's Profile View All Posts By User U2U Member

New Topic New Poll New Reply


go to top






Website design and SEO by Studio Montage

All content © 2001-16 LocostBuilders. Reproduction prohibited
Opinions expressed in public posts are those of the author and do not necessarily represent
the views of other users or any member of the LocostBuilders team.
Running XMB 1.8 Partagium [© 2002 XMB Group] on Apache under CentOS Linux
Founded, built and operated by ChrisW.