Printable Version | Subscribe | Add to Favourites
<<  1    2    3  >>
New Topic New Poll New Reply
Author: Subject: MK IndyBlade
Banana

posted on 27/12/16 at 08:19 PM Reply With Quote
Yes gear stick in the same position, not found it to be an issue. Mind you, i have long arms..

Took my brother and sister in law for passenger rides this weekend, it was hilarious. I don't think i went much above 60mph, but she was screaming. haha

View User's Profile View All Posts By User U2U Member
CosKev3

posted on 28/12/16 at 11:49 AM Reply With Quote


I like to take mine up to about 7000rpm threw the gears then say to them 'goes well doesn't it?'

Then hit them with a WOT run up to the rev limiter

View User's Profile View All Posts By User U2U Member
Banana

posted on 17/2/17 at 09:23 PM Reply With Quote
Not updated this in a good while, but have been busy with the car.

I've been focused mainly on mechanical aspects since ive had her, and really need to start addressing the cosmetic side of things.

Would like to replace the canvas boot cover, get new rear lights and powder coat the roll bar and wheels black.
Got some black cycle wings to go on, as its all a bit yellow for me atm.

Any suggestions welcome..

Lots of little jobs done, but these are the things i remember.

Oil and filter change.

New throttle pedal and stop. Original stop was on the floor, so i made a new one behind the pedal.



New bike battery with 180 CCA, to replace the car battery (10kg saving)



D1 spec quick release acquired from a helpful person on here..



Got some carbon stone protectors and carbon look cycle wings. To reduce the yellowness of the car.



New steering bearing fitted to remove play. I couldn't see a satisfactory way of fitting it inside the bulkhead, so its gone engine bay side. (studs to be trimmed still..)



Exhaust silencer wrapped, to cover the bracket i had to cut off. And to stop passengers burning themselves.



Battery relocated to footwell, and footrest made up to hide it.



Finally got the speedo working! Got some M8 tab washers, and fitted to diff output.



Took a trip to AB Performance, to get get carbs jetted to 132 and balanced. Compression is even across all four cylinders, and it pulls SO much better now.



Did a snowy/sleety trackday at Woodbridge - car ran faultlessly, but handled like a pig. Shall be looking at the geometry next.


View User's Profile View All Posts By User U2U Member
Banana

posted on 19/3/17 at 07:49 PM Reply With Quote
Well many more jobs done over the past few weeks, but struggling to remember half of them.

Pleased with myself, as all dash/speedo/Gear Indicator etc are now working.

Sorted the rectifier issue - it was purely down to them being shite, basically.
I found a YBF 125 reccy in dads garage (twice the size of the Blade one?!) stuck this on and it works fine.
Before i burnt out the final Chiese reccy, i wanted to ensure it was as cool as possible. So fitted a fan/heatsink to the underside on an ally sheet, however it still only lasted 5 mins.
No matter, the new reccy is now getting nicely cooled.

Sorted a dragging rear brake - screwed the piston in a quarter turn and all is well. No more black rear wheel.

Rear stone guards and front cycle wings Tigersealed on, which really improve the look in my opinion.

Yoko A032's fitted. and a new gear lever purchased. Not sure how im going to fit this though, as there seem to be a prop shaft in the way..

Really need to get he geometry looked at tho, as it really doesn't feel planted or predictable on road. Apparently MK are getting a flat floor and corner weight facilities setup over the coming weeks, so will probably go there.











[Edited on 19/3/17 by Banana]

View User's Profile View All Posts By User U2U Member
CosKev3

posted on 19/3/17 at 07:57 PM Reply With Quote
Looking good

Sorting the jobs out nicely

View User's Profile View All Posts By User U2U Member
Banana

posted on 19/3/17 at 10:24 PM Reply With Quote
Cheers Kev.

I noticed on another thread you posted a pic of your gear lever in relation to the prop.

Ive just bought the same lever, but my prop is way higher than yours and no way the lever will fit as you have mounted it.

I wonder if my engine has been mounted higher or something.. Is yours a Blade?

View User's Profile View All Posts By User U2U Member
CosKev3

posted on 19/3/17 at 10:37 PM Reply With Quote
No mines a R1.

I've converted mine to from a car engine to BEC so not a very good comparison really!

It's strange though how high your prop is,how is the centre bearing mounted?

View User's Profile View All Posts By User U2U Member
Banana

posted on 19/3/17 at 10:41 PM Reply With Quote
Can't remember, will have a look tomorrow and post some pics.
View User's Profile View All Posts By User U2U Member
Banana

posted on 20/3/17 at 08:57 PM Reply With Quote
Looking back towards diff



Looking foward under current gear lever



New Lever sitting on top of prop





[Edited on 20/3/17 by Banana]

View User's Profile View All Posts By User U2U Member
CosKev3

posted on 20/3/17 at 09:22 PM Reply With Quote
Will it fit on the passenger side of the tunnel?
View User's Profile View All Posts By User U2U Member
Banana

posted on 20/3/17 at 10:05 PM Reply With Quote
Nah, the prop is central, with barely an inch either side of it... Bit of a bugger.

Maybe it's a a large diameter prop.

View User's Profile View All Posts By User U2U Member
<<  1    2    3  >>
New Topic New Poll New Reply


go to top






Website design and SEO by Studio Montage

All content 2001-16 LocostBuilders. Reproduction prohibited
Opinions expressed in public posts are those of the author and do not necessarily represent
the views of other users or any member of the LocostBuilders team.
Running XMB 1.8 Partagium [ 2002 XMB Group] on Apache under CentOS Linux
Founded, built and operated by ChrisW.