Printable Version | Subscribe | Add to Favourites
New Topic New Poll New Reply
Author: Subject: Dell tower problem,as its stopped working!
steve m

posted on 13/1/21 at 02:10 PM Reply With Quote
Dell tower problem,as its stopped working!

I have a D08S dell mini tower system, that has worked faultlessly for a year

I had installed some flight sims to play on, but had lost the usb fly lead from my old Jr transmitter to PC

so ordered one off fleabay, plugged it into the PC, then the transmitter, and the pc has shut down, and will not start up, no matter what

Ive downloaded a user manual for the PC, assuming there would be an internal fuse, but there doesnt appear to be one

any ideas ? andd the lead has gone in the bin !!!


Thats was probably spelt wrong, or had some grammer, that the "grammer police have to have a moan at

View User's Profile View All Posts By User U2U Member

posted on 13/1/21 at 02:18 PM Reply With Quote
first off leave it completely powered off, and unplugged from the mains for at least an hour, then try again.
also unplug all devices leaving you with just a keyboard and screen, and see if that helps

View User's Profile View All Posts By User U2U Member

posted on 13/1/21 at 02:53 PM Reply With Quote
If I'm understanding correctly you bought a USB cable from Ebay?

If so that could have caused the problem. A number of USB leads we've seen pass through my work (where we develop USB interface electronics) have been pretty rubbish. Often the cheaper end ones are poorly made and on some the connections are not in the right pin order in the connectors. If you connect them it can cause the host (PC) or peripheral (keyboard, mouse etc.) to not work or fail.

To be honest I've not had an example where the PC itself has simply given up like you describe though!

View User's Profile View All Posts By User U2U Member

posted on 13/1/21 at 02:57 PM Reply With Quote
What exactly do you mean by "will not start up, no matter what"

Are you saying that when the mains cable is plugged in and mains turned on, there is no response from the computer, that is no fans run, no lights on?

You've obviously checked the fuse in the mains plug and tried a different mains cable that is known to be working?

If the pc shows no signs of being powered up, then it could be the psu is dead.

You can buy a pc supply tester (about 5) that allows you to test each cable, I have one you can borrow, otherwise you can use a volt meter to test but the interlock in the main atmAT connector needs jumping else the supply won't turn on.

See ebay, PC Power Supply Tester with 20/24 Pin SATA HDD Connectors, 5.84, UK based seller.

Alternativelu depending on what connectors the psu has, you can unplug most of them to start diagnosis.

[Edited on 13/1/21 by 02GF74]

View User's Profile View All Posts By User U2U Member
steve m

posted on 13/1/21 at 03:14 PM Reply With Quote
As soon as i plugged the usb lead into the transmitter in, the PC went off, and has not come on at all, no fans, no lights, nothing!

The plug fuse is fine, and on the back of the PC, on the power supply, there is a green light, and a hold in button ? and if that is held in, the fans operate, so power is getting in, but once released fans stop,

Im now using my crappy garage Laptop, that thankfully with hdmi lead to the main screen,, a crappy plug in keyboard and mouse, im back online, but

the screen graphics are poor, but livable for the moment!!


Thats was probably spelt wrong, or had some grammer, that the "grammer police have to have a moan at

View User's Profile View All Posts By User U2U Member

posted on 13/1/21 at 03:37 PM Reply With Quote
is there an internal fuse that has popped ?

who cares who wins
pass the pork pies

View User's Profile E-Mail User View All Posts By User U2U Member   theconrodkid 's Aim   theconrodkid 's Yahoo

posted on 13/1/21 at 03:38 PM Reply With Quote
ok, now we're getting somewhere. Your PC is similar to my Dell Optiplex 960. It too has a button and green LED on the rear. The purpose of this I believe is to discharge the power supply prior to messing inside. Like yours, when I press the button with mains power in, the fans sound.

Dells like these temporarily power up when the main is switched on (a common feature on; no idea why) - I take it yours does not?
It then needs the on/off button on the front panel to be pressed.

There could be a fault with the power supply and/or the motherboard and/or power switch.

Is there a LED on the motherboard, if so, does it light up?

I would recommend starting with the power supply, unplug all cables and try the tester on each plug I listed above. Then plug in only the main power connector to mother board and see how that goes - if the mobo is not fucked, the computa should least get the diagnoistc light to flash. If it gets past that stage, you can plug in a disk. There may be a cable for powering USB so unplug that (I am not familiar with the internals but if you get stuck, I will look for the service manual).

Some additional stuff here:

View User's Profile View All Posts By User U2U Member
Mr Whippy

posted on 13/1/21 at 03:55 PM Reply With Quote
Once you have the stupid thing working I'd recommend just buying a rc sim controller as it saves wear on the real controller and best of all runs on the computers power instead of batteries. I've had a real flight one for years.
View User's Profile Visit User's Homepage View All Posts By User U2U Member   Mr+Whippy 's Aim
steve m

posted on 13/1/21 at 04:33 PM Reply With Quote
There does not appear to be any inside fuse, nor anything in the manuals for either the PC D08s or motherboard,
unless there is one inside the PSU ?? but i cant seem to have any idea how it comes apart ?

MY rc controller is an old 35meg JR2610, MY dx7 are safely tucked away


Thats was probably spelt wrong, or had some grammer, that the "grammer police have to have a moan at

View User's Profile View All Posts By User U2U Member

posted on 14/1/21 at 09:55 AM Reply With Quote
I'm looking at the manual now - Dell Opitplex 3020 - mini tower - very similar to mine. These appear to be office PCs, what I mean by that is they are incapable of running high power/performance graphics cards and multiple disk drives so the power supply is puny.... so that means it will be cheap - you should be able to pick one up on eBay for under 19. e.g. 164245617027

P 16 shows the power supply has 2 connectors: a 4-way and 8-way to the mother board (power to disks is via a connector from the mother board). The tester I mention earlier should be able check it out. It doesn't have the wide connector (20 pin?) which has the interlock.

I can see 4 cross-head screw on the rear - you would remove these and very likely the panels slot together allowing you to get at the innards. There may be a fuse inside but make sure you discharge the PSU components with the button as I mention above.

I don't know what your plans are but these are the options I suggest.
1. remove power supply (these PCs are modular so quick and easy to do) or at least unplug the 2 power connectors. If you have a DVM and know the pin out for the connectors, then check the voltages
2. as above but use the PC power supply tester
3. replace the power supply

p 24 shows system board (motherboard) - there are numerous connectors on there - disconnect as many as possible so that there bare minimum are left in order to get the computer to boot from BIOS, namely plug in the 2 power connectors and remove the following:

1. SATA connectors
3. front USB2.0 connector
4. internal USB connector
7. front audio connector
14. PS2 serial port connector
19. HDD_ODD power cable connector
20. HDD_LED connector
21. speaker connector

If all is well, the PC won't boot, and may not even get to BIOS but it should provide diagnostic beeps or lights - see section 5 Power LED Diagnostics.

I notice next to the blue SATA socket is what appears to be a yellow LED- if that is the case, does it light up when mains cable is plugged in, if not, does it come on when the power supply discharge switch is pressed?

Worst case scenario, replacements are around 50 for the whole thing so it is not as if it was a 4k gaming rig hopefully data on the HD survived.

Good luck

View User's Profile View All Posts By User U2U Member
steve m

posted on 14/1/21 at 11:23 AM Reply With Quote
Thank you for this very detailed reply!!

My power supply isnt the same as the ebay link, its long and thin, and ive had it apart, and it definitely does not have a fuse inside

I could buy another PSu and fit it, but as i dont know if there could be any other damage, its now scrapped, well confined to the growing pile of none working stuff in the garage

Ive transferred all the saved data, already, as had a caddy form my 1tb HDD,, so thats not a problem

Also, i have contacted the Ebay seller, that i bought this unit from, one year ago, and he has assured me that a replacement unit of the same spec,
My HDD will slot straight in, and work, so thats what ive done, bought another unit, that comes with another 1TB HDD all for 80

Not sure if i will swop the HDD over, or just transfer that data over,

Again, thank for your help



Thats was probably spelt wrong, or had some grammer, that the "grammer police have to have a moan at

View User's Profile View All Posts By User U2U Member

New Topic New Poll New Reply

go to top

Website design and SEO by Studio Montage

All content 2001-16 LocostBuilders. Reproduction prohibited
Opinions expressed in public posts are those of the author and do not necessarily represent
the views of other users or any member of the LocostBuilders team.
Running XMB 1.8 Partagium [ 2002 XMB Group] on Apache under CentOS Linux
Founded, built and operated by ChrisW.