Printable Version | Subscribe | Add to Favourites
New Topic New Poll New Reply
Author: Subject: Random/instantaneous flooding
Chaz

posted on 4/7/21 at 08:11 AM Reply With Quote
Random/instantaneous flooding

Hello!

I seem to have a problem with my MS2 setup (zetec, ITBs) and wondering has anyone had similar?

I have managed to get megasquirt up and running, started the autotune etc so all going well. After an unknown amount of time, sometimes 1 min sometimes 15 mins the injectors (definately 2 but possibly all 4) dump a mammoth amount of fuel in which immediately stalls the car. Fuel then spills out the ITBs (yes!) and begins to boil on the closed valve heads and in the cylinders. Once it set fire to the exhaust!

Anyone else had this? I think its an earthing issue, the problem is i dont know which earths i need to be checking? Inside the ECU or outside (wiring). The fact its intermittent and only when moving could mean wiring external to ECU.

Some help would be appreciated thank you!

[Edited on 4-7-21 by Chaz]

View User's Profile View All Posts By User U2U Member
coyoteboy

posted on 4/7/21 at 09:30 AM Reply With Quote
Since it's repeatable, I'd be logging it to see what happens!

Never heard of this problem specifically but it could be a combo of a few things happening.





Report your local potholes, it actually works!

View User's Profile Visit User's Homepage View All Posts By User U2U Member
obfripper

posted on 4/7/21 at 01:00 PM Reply With Quote
I have had injectors locking open due to the u4 fet driver chip failing, however this was with an 2004 ms1 with the original MC34151 chip which has been superceded to a IXDI404 which is pretty reliable. The fault was also permanent, instantly flooding during the priming pulse before cranking at every ignition on.

Your situation sounds like it could be linked to an incorrect setting in tunerstudio triggering massive acceleration enrichment. It may be worth starting a new project in tunerstudio from scratch, using only your engine details to calculate req_fuel and fuel maps. You should be safe to export the current ignition map to the new project.

Dave

View User's Profile View All Posts By User U2U Member
number-1

posted on 4/7/21 at 01:36 PM Reply With Quote
It might be worth seeing if anyone else runs the same ECU and can send a base map to you. Just out of curiosity....What fuel pressure reg are you running at at what PSI? I had similar fuel spillage and it was the FPR running too high a pressure
View User's Profile View All Posts By User U2U Member
Chaz

posted on 4/7/21 at 05:44 PM Reply With Quote
I think my fuel pressure is fine, static itís about 3.3 bar but drops to 3 bar in dynamic flow. Thanks for the idea of someone running my tune but I doubt anyone would want to put this tune into their car!

I have checked acceleration enrichment but I actually have it turned off because of this. The other part of Ďaccelerationí enrichment is the VE table as Iím using the combo of TPS and MAP for ITB tune. I didnít press the accelerator quickly as I want tuner studio loop to be able to learn before it stalls.

Yes I will try logging it, think I tried last time but didnít spot anything unusual. Will try again

View User's Profile View All Posts By User U2U Member
coyoteboy

posted on 5/7/21 at 11:35 AM Reply With Quote
Share your logs, I can take a little scout about too.





Report your local potholes, it actually works!

View User's Profile Visit User's Homepage View All Posts By User U2U Member

New Topic New Poll New Reply


go to top






Website design and SEO by Studio Montage

All content © 2001-16 LocostBuilders. Reproduction prohibited
Opinions expressed in public posts are those of the author and do not necessarily represent
the views of other users or any member of the LocostBuilders team.
Running XMB 1.8 Partagium [© 2002 XMB Group] on Apache under CentOS Linux
Founded, built and operated by ChrisW.