Printable Version | Subscribe | Add to Favourites
New Topic New Poll New Reply
Author: Subject: Zetec oil pressure
zammobhoy

posted on 2/11/23 at 08:40 PM Reply With Quote
Zetec oil pressure

Hi Folks,

I'm running a Zetec/ST170 engine that has an oil pressure issue:

A couple of years ago I suffered a massive over-revving incident which destroyed the oil pump along with several other components.

After rebuilding with new oil pump, I seem to be having difficulty building oil pressure from cold. I am getting round this by cranking the engine for a minute or so to prevent the engine running with low oil pressure after startup.

Once started/warmed up, it's fine until the next time I come to start the next day or whenever.

Anyone come across this before? The pump was advertised has 'upgraded', but that could mean anything I guess, it wasn't an OEM part.

Any advice appreciated,

Cheers,

Paul.

View User's Profile E-Mail User View All Posts By User U2U Member
perksy

posted on 4/11/23 at 11:03 AM Reply With Quote
You've checked the oil pump releif valve and made sure the gauge is reading ok?

Have you used a different brand/type of oil filter?

View User's Profile View All Posts By User U2U Member
zammobhoy

posted on 4/11/23 at 07:43 PM Reply With Quote
Just using the standard warning light to display pressure.

Pressure definitely low on cold startup because there is some rattling

Always used the same type of oil filter, think it's off a Renault 5

View User's Profile E-Mail User View All Posts By User U2U Member
perksy

posted on 4/11/23 at 08:02 PM Reply With Quote
The rattling when it starts worries me a bit and I'd be checking the oil pressure both cold and hot with a gauge

Not a great lover of standard oil pressure warning lights

I'd also be checking the oil pressure releif valve isn't sticking

View User's Profile View All Posts By User U2U Member
zammobhoy

posted on 5/11/23 at 08:38 PM Reply With Quote
Thanks for the input,

Iíll just haul the engine out and take a look.

Just wondered if anyone had experienced similar issues

View User's Profile E-Mail User View All Posts By User U2U Member
gremlin1234

posted on 5/11/23 at 09:01 PM Reply With Quote
what oil are you using? modern oils are far thinner than those of old.

thinking about it...
check the oil filter has a working anti-drain valve/flap, so you don't have to refill the filter each time you start from 'cold'

View User's Profile View All Posts By User U2U Member
perksy

posted on 5/11/23 at 10:09 PM Reply With Quote
I wouldn't haul the engine out just yet without doing some more checking

You could rig up a mechanical oil pressure gauge first to get cold and hot readings

The rattling at cold, is it coming from the top or bottom of the engine?

Does your oil pressure light go out imediately when you start it from cold or does it take awhile?

View User's Profile View All Posts By User U2U Member

New Topic New Poll New Reply


go to top






Website design and SEO by Studio Montage

All content © 2001-16 LocostBuilders. Reproduction prohibited
Opinions expressed in public posts are those of the author and do not necessarily represent
the views of other users or any member of the LocostBuilders team.
Running XMB 1.8 Partagium [© 2002 XMB Group] on Apache under CentOS Linux
Founded, built and operated by ChrisW.